MailScanner restart fails?

Denis Beauchemin Denis.Beauchemin at USHERBROOKE.CA
Thu Nov 14 16:53:49 GMT 2002

Le jeu 14/11/2002 à 11:34, Julian Field a écrit :

> >And when I try to restart MailScanner it gives this output:
> >
> >[root at linuxgw rules]# /etc/rc.d/init.d/MailScanner restart
> >Shutting down MailScanner daemons:
> >          MailScanner:       We haven't got any child processes, which
> >isn't right!, No child processes at /usr/sbin/MailScanner line 191.
> >We have just tried to reap a process which wasn't one of ours!, No child
> >processes at /usr/sbin/MailScanner line 194.
> This is down to the exact order in which the processes are shut down. I
> have removed this error message from the next release as it causes confusion.


I don't believe that not printing the error message will make things OK
since a restart does a stop followed by a start and the start can't
succeed unless the stop has stopped all processes (which it doesn't).

PS: The versions I run (mailscanner-4.04-1 and mailscanner-4.05-3) still
exhibit this problem.
Denis Beauchemin <Denis.Beauchemin at>
Université de Sherbrooke

More information about the MailScanner mailing list