MS4.x config/runtime issues

Julian Field mailscanner at
Fri Nov 8 10:42:26 GMT 2002

At 10:08 08/11/2002, you wrote:
>On Thu, 7 Nov 2002, Julian Field wrote:
> > At 17:18 07/11/2002, you wrote:
> > >1. bin/MailScanner/ :  MS gave a message:
> > >      Your vendor has not defined the Sys::Syslog macro _PATH_LOG at [...]
> > >    By commenting out the line:
> > >      eval { Sys::Syslog::setlogsock('unix'); }; # Doesn't need syslogd -r
> > >    this then worked, apparently with no ill effect.
> > >    Seems to be  sort of Perl/Solaris interaction (Perl 5.6.0; Solaris 8).
> > >    Does the MS code need to be more tolerant, and/or autoconf'd?
> >
> > The failure message doesn't actually cause any harm. Basically it tries to
> > use a domain socket instead of a UDP socket, so you don't have to open up
> > your syslogd to accept UDP logging requests from other machines (which
> > might be used as a DoS attack on your server by forcing gigabytes of syslog
> > traffic).
>Thanks, Julian.  Overall: Good News, No News (yet) and Bad News.
>So, in reverse order...
> > Please can you try the attached patch to to see if it removes the
> > error message on your system.
>The patch doesn't seem to remove the message; the versions seem
>indistinguishable in behaviour.

Can you try this:

use Sys::Syslog;
use Carp;

eval { $SIG{'__DIE__'} = 'IGNORE';
        croak "Bye bye";
$SIG{'__DIE__'} = 'DEFAULT';
print "Hello there\n";

and tell me what it outputs. On my system I just get "Hello there". If the
"__DIE__" handler isn't working as expected, it will stop with an error.

>Note also that both versions have a further problem.  This only comes to
>light after five of the previous messages had been issued.  (Because of
>that previous behaviour, my trials had never got as far as revealing the
>further problem.)  After about five of the:
>    Your vendor has not defined the Sys::Syslog macro _PATH_LOG at [...]
>it then gives:
>    We haven't got any child processes, which isn't right!, No child
> processes at /opt/MailScanner/bin/mailscanner line 191.
>    We have just tried to reap a process which wasn't one of ours!, No
> child processes at /opt/MailScanner/bin/mailscanner line 194.

For now, you can comment out the setlogsock line.

> > I thought it was a good idea at the time, but setups such as yours hadn't
> > occurred to me. On reflection it may be better to remove the check. I will
> > still look for a q1 or qf directory though, in an attempt to find split
> > queue directories which sendmail will use if it finds them. So you can get
> > it going now, the minimal patch to is attached to this message.
> > There is actually just 1 extra line of code.
>Good News:  That seems fine.  Many thanks.

Julian Field                Teaching Systems Manager
jkf at         Dept. of Electronics & Computer Science
Tel. 023 8059 2817          University of Southampton
                             Southampton SO17 1BJ

More information about the MailScanner mailing list