mailscanner and maillog

Nick Phillips nwp at LEMON-COMPUTING.COM
Thu Jun 20 01:07:59 IST 2002

I suggest people look at this as an example of how to make it *really hard*
for anyone to help.

It's completely unreadable.

If people can't be bothered to format a mail in such a way as to make it easy
to read, then why would the people who they want help from bother to read it?

If on the other hand people are incapable of formatting a mail such that it is
easy to read, I might suggest that they are also unlikely to be capable of
doing a reasonable job of more complex tasks - like for example whatever it
is that they are asking for help with.

Either way, it's a big demotivator.

BTW Matt, don't take it personally; you're not the first and I'm sure you
won't be the last. You just happen to be the sender of the mail that's pricked
me into writing this. You are at least polite, which believe it or not, is not
always the case.



On Wed, Jun 19, 2002 at 04:05:57PM -0400, Matt Doherty wrote:
> Thank you for the info.
> There was a line in the /etc/syslog.conf file ">mail.none /var/log/maillog
> <" I changed it to ">mail.debug /var/log/maillog <" (none to debug)
> restarted syslog and still no go.
> Upon reading your next option I also noticed there was a missing "-r" switch
> in the line from /etc/rc.d/init.d/syslog .. I did a restart and
> unfortunately no go.. I restarted mailscanner.. then a tail -f
> /var/log/maillog and no action..:( at that point I can send mail still but
> all of a sudden I cant receive any new I tried sending mail from a
> remote domain over and over and got no erros on the sendees side but on my
> receiving end (with mailscanner) I received no new mail.. being in a panic
> .lol.. I did a mailscanner stop and then a sendmail start and immediatly
> received all mail from 10 minutes ago from the remote domain.. These test
> emails have no attachments and have as little as one word of text in both
> subject and body..permissions for any files including the maillog have not
> been altered since the beginning of mailscanner install...from yesterdays
> fresh new install of mailscanner the only thing new today was the new
> version you put out on the ftp site..mailscanner-3.20-6.i386.rpm -U option
> was used.. that i did... (not saying this problem wasn't an issue yesturday,
> ,it was).. I have found something in Google about a statement in a
> procmail.rc file? I did a locate for it and its not on my RH7.2 system at
> least. apparently someone had a issue with maillog not being written to and
> a line in that file was the fix..oh well, I hope to get this thing working
> . I like it.. As with some unix programs i have to put up a small
> fight..but its worth it to keep windows and gates away from my world..:)
> Thank You Much for speedy reply!! however I am still stuck.:(
> I did check all files and reread the mailscanner.conf file.. no changes to
> the conf file were needed.. It kept my previous settings.. sophos etc..

Nick Phillips -- nwp at
Excellent day to have a rotten day.

More information about the MailScanner mailing list