problems with sophos autoupdate

Aldas Nabazas aldas at
Tue Aug 6 08:05:22 IST 2002

JF>> At 13:39 05/08/2002, you wrote:
>>>My Sophos 3.57 got out of date, so decided to install 3.59 and also
>>>upgraded my Mailscanner to 3.22-10

JF>> Did you install Sophos 3.59 using my
JF>> /usr/local/MailScanner/bin/Sophos.install script?

>>>All works fine, but i get error when i'm trying to download ide files
>>>using mailscanner's autoupdate for sophos {noticed that sophos don't
>>>provide any update script with their virus scanner}
>>>Could not calculate Sophos version number, Bad file descriptor at
>>>./autoupdate line 77.

JF>> Delete everything under /usr/local/Sophos (except /usr/local/Sophos/bin/*)
JF>> and install it using my Sophos.install script. That does an "autoupdate" as
JF>> its last action.
JF>> --
JF>> Julian Field                Teaching Systems Manager
JF>> jkf at         Dept. of Electronics & Computer Science
JF>> Tel. 023 8059 2817          University of Southampton
JF>>                              Southampton SO17 1BJ

That was yesterday

Thank You Julian,

yeah it worked , but now when i'm running
/usr/local/Sophos/bin/autoupdate , i got this error again

looked over your instal script, and can't get why it works for first
time, but when i'am running it i got errors? :)

The problem was here
original autoupdate : $VDLDir = "../lib";
my autoupdate       : $VDLDir = "/usr/local/Sophos/lib";

I don't know maybe i've chaged it or maybe not, well it doesn't matter
now, i'm glad that it is working perfect as it worked till upgrade. {i
have never upgraded mailscanner and sophos before}

Sorry :)

More information about the MailScanner mailing list