Can't Install Mail Scanner,

Julian Field jkf at
Tue Apr 9 10:11:46 IST 2002

Glad to hear you got it fixed.
I'm not a user of those graphical RPM managers (I just type the command :-)
but I can't see why it would fail, when it works from the command line.

At 01:14 09/04/2002, you wrote:
>Hi Julian,
>Thanks for the reply.  I have sorted it out and it now appears to be
>running smoothly although I am yet to do some serious testing.
>FYI and for anyone else that may bump into the same problem.
>I found the rpm --rebuilddb command and it ran without reporting any
>problems.  I tried to install the rpm again by right clicking on the
>file in a graphical file manager as I did before then and chose the
>install option.  I received the same message as before.  I then tried
>the command line specified in the Installation guide and it said the
>package was already installed.  I tried again with the --force option
>and it spewed out screens of information all of which looked good except
>for a couple of things that looked like minor problems.  I ran the
>sophros.install script again for good measure and it worked ok to.
>I Sent a test virus through the server and it picked it up no problem.
>This looks like quit a robust system and I'm looking forward to getting
>rid of my old solution.
>Thanks Again
>-----Original Message-----
>From: Julian Field [mailto:jkf at ECS.SOTON.AC.UK]
>Sent: Tuesday, 9 April 2002 12:11 AM
>Subject: Re: Can't Install Mail Scanner,
>At 04:06 08/04/2002, you wrote:
> >Hi There,
> >I m trying to install Mailscanner on my Redhat Linux 7.1 machine.
> >I have downloaded the .rpm file a couple of times and get the same
> >Logged on to the consol as root if I choose the install option I get
> >following error message.
> >db3 error(-30989) from dbcursor -> c_get: DB_RUNRECOVERY: Fatal error,
> >database recovery.
> >It comes up twice with the only option being OK
> >If I press ok it tells me that there were problems and would I like to
> >ignore them.  If I do then the program doesn t work.
> >Some of the files are installed but some are missing. (sophoswrapper
>for one)
> >Any ideas what I can do to fix this problem.
> >David.
> >PS I tried to search the list archive but I could not connect to it.
>If you are getting db3 errors, then something is broken in your RPM
>database on your system. Read "man rpm" and look for the option to
>the database.
>Also, try downloading the MailScanner RPM again, just in case it got
>corrupted on its way to you (very unlikely but it could happen).
>No-one else has reported any problems with the latest RPMs, so it must
>be a
>problem specific to your system.
>Julian Field                Teaching Systems Manager
>jkf at         Dept. of Electronics & Computer Science
>Tel. 023 8059 2817          University of Southampton
>                              Southampton SO17 1BJ

Julian Field                Teaching Systems Manager
jkf at         Dept. of Electronics & Computer Science
Tel. 023 8059 2817          University of Southampton
                             Southampton SO17 1BJ

More information about the MailScanner mailing list