Can't Install Mail Scanner,

Julian Field jkf at
Mon Apr 8 15:11:08 IST 2002

At 04:06 08/04/2002, you wrote:
>Hi There,
>I m trying to install Mailscanner on my Redhat Linux 7.1 machine.
>I have downloaded the .rpm file a couple of times and get the same result.
>Logged on to the consol as root if I choose the install option I get the
>following error message.
>db3 error(-30989) from dbcursor -> c_get: DB_RUNRECOVERY: Fatal error, run
>database recovery.
>It comes up twice with the only option being OK
>If I press ok it tells me that there were problems and would I like to
>ignore them.  If I do then the program doesn t work.
>Some of the files are installed but some are missing. (sophoswrapper for one)
>Any ideas what I can do to fix this problem.
>PS I tried to search the list archive but I could not connect to it.

If you are getting db3 errors, then something is broken in your RPM
database on your system. Read "man rpm" and look for the option to recover
the database.
Also, try downloading the MailScanner RPM again, just in case it got
corrupted on its way to you (very unlikely but it could happen).
No-one else has reported any problems with the latest RPMs, so it must be a
problem specific to your system.

Julian Field                Teaching Systems Manager
jkf at         Dept. of Electronics & Computer Science
Tel. 023 8059 2817          University of Southampton
                             Southampton SO17 1BJ

More information about the MailScanner mailing list